R/E/P Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: [1]   Go Down

Author Topic: IC4 swivel mount loose  (Read 577 times)

BluegrassDan

  • Newbie
  • *
  • Offline Offline
  • Posts: 29
  • Real Full Name: Dan Boner
IC4 swivel mount loose
« on: January 10, 2024, 02:05:02 AM »

Is the U87's IC4 swivel mount supposed to have a flat rubber washer inside the circular connector? Mine is very loose when screwed into the mic and it seems like such a washer would remedy this.
Logged
Dan Boner
Professor/Program Director
Bluegrass, Old-Time, and Roots Music Studies
East Tennessee State University

klaus

  • Moderator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 2218
Re: IC4 swivel mount loose
« Reply #1 on: January 10, 2024, 04:41:57 AM »

I only have the SCGT3 version here, which is a predecessor and close variant of the IC4. No play and no washer. If you have play between XLR insert and housing, stip th amount to its sub-components and investigate for loose locknuts.
Logged
Klaus Heyne
German Masterworks®
www.GermanMasterworks.com

afterlifestudios

  • Full Member
  • ***
  • Offline Offline
  • Posts: 200
  • Real Full Name: John Raham
Re: IC4 swivel mount loose
« Reply #2 on: January 10, 2024, 10:11:36 PM »

Is the U87's IC4 swivel mount supposed to have a flat rubber washer inside the circular connector? Mine is very loose when screwed into the mic and it seems like such a washer would remedy this.

No washer in my specimen
Logged
Pages: [1]   Go Up
 



Site Hosted By Ashdown Technologies, Inc.

Page created in 0.071 seconds with 21 queries.