R/E/P Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: [1]   Go Down

Author Topic: Need help troubleshooting a problem with a (vintage) U67  (Read 404 times)

Koen

  • Newbie
  • *
  • Offline Offline
  • Posts: 33
  • Real Full Name: Koen Gisenesd
Need help troubleshooting a problem with a (vintage) U67
« on: September 30, 2019, 11:28:56 am »

Hello there, I hope everyone is doing well here!
For a while now I have a problem with a U67: The symptom is an intermittent one: some days, it is just fine, but all of a sudden it can start crackling. The problem seems to be 'mechanical' : I used to rattle the cable or tap the tuchel connector and often the crackling went away (sometimes for days, sometimes for hours). At first I thought the valve was maybe on the way out, but it turned out to be fine (I checked and have replaced it with several working valves and put the valve in another U67 etc. but the problem persisted with different valves). I assumed then that it was some kind of a connection problem in or around the tuchel. I took the tuchel apart completely and checked solder point etc, I also checked the male part in the microphone etc. Nothing wrong apparently.
Now I discovered something that might lead to something: when I slightly loosen the 'screw'-on ring (that fixes the body shell on the mic) the crackling goes away (just like it did by tapping it) BUT: when I turn the ring too tight, the sound of the microphone shuts off completely (untill I loosen the ring again)...!
Does this ring any bell with anyone here? Maybe Klaus has encountered this kind of problem before?
Many Thanks,

Koen Gisen,
Gent - Belgium.
Logged

afterlifestudios

  • Full Member
  • ***
  • Online Online
  • Posts: 102
  • Real Full Name: John Raham
Re: Need help troubleshooting a problem with a (vintage) U67
« Reply #1 on: October 01, 2019, 01:00:50 am »

Someone else will probably offer better info, but here's what I would try:
Since it sounds like you have other u67's around, you could try to narrow it down by using this mic temporarily (*) with another working u67 system's PSU and cable .  If the problem persists, you can probably rule out the cable and supply.  Then you could swap a known working head assembly, and then you'd know if it was caused by capsule or amplifier.  Divide and conquer... 

But if I had to guess, I'd say maybe your female tuchel insert socket of the cable is deteriorating and being squeezed to the point where something is shorting.  Get a big magnifying glass and inspect the soldering and the female insert itself.

(*) temporarily because b+ and heater voltages might be slightly different for each mic/PSU combination)

Logged

Koen

  • Newbie
  • *
  • Offline Offline
  • Posts: 33
  • Real Full Name: Koen Gisenesd
Re: Need help troubleshooting a problem with a (vintage) U67
« Reply #2 on: October 01, 2019, 03:49:04 am »

Hi, thanks for your advice.
Actually, I already did all this. PSU and cable and capsule work correct on other u67 amplifier bodies.
I'm quite convinced it has something to do with eiter the tuchel itself, or, more likely some body shell contact thing (given the fact that if I tighten the ring too much it completely shorts the mic). I'm puzzled about where exactly the 'shorting' can occur when tightening the ring...
Logged

afterlifestudios

  • Full Member
  • ***
  • Online Online
  • Posts: 102
  • Real Full Name: John Raham
Re: Need help troubleshooting a problem with a (vintage) U67
« Reply #3 on: October 01, 2019, 12:15:16 pm »

It seems you did sort of the inverse of what I would do..  I’d try to find out if that u67 mic works fine with another supply/cable...  (Tightened right up.)

The tightening could possibly cause the short in the female tuchel socket (on the cable) by pressing the female insert bottom (where the solder joints and connections are) into the metal work of the tuchel connector causing some wires to short. In your case it could be audio + and - shorting resulting in no sound (cancellation).  But it could be much worse if a short sends high voltage somewhere it shouldn’t!

Anyway, this is all speculation on my part, but I’d try to see if the mic is fine on another cable/supply.  Those (plastic/Bakelite?) female tuchel inserts are a bit of a weak spot, and may not be holding in place inside the metal work, allowing the force of the tightening of the metal threads to the mic to push the insert down which crams some wires together to cause a short.

Logged

klaus

  • Moderator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1660
Re: Need help troubleshooting a problem with a (vintage) U67
« Reply #4 on: October 01, 2019, 12:47:07 pm »

When I investigate a symptom or defect I am not familiar with, I first try to isolate problems areas: is it a capsule, amp, cable or power supply problem?

In your case, that task is an easy one (and I believe you have already done it).

If I can trigger the intermittent or noisy audio by speaking or popping into the capsule, it's capsule related, and usually caused by some form of contamination.

If not, I move forward in a binary fashion which is a bit like John suggested, above: substitute one, and only one, component at a time - tube, cable, power supply - and observe after every change whether the symptom disappears or remains. If it remains, substitute the next, and so on.

That is easier said than done when you only have one mic system available. In your case, you did the right thing by visually inspecting the system closely and substituting what was available to you- another tube- and then communicating the problem to a larger, hopefully more experienced audience. 

The U67 has a couple of weak electrical connections and contact points that can become intermittent and break down with time, torquing of the mic amp frame, or applying other types of physical force: Several electrical connections between the two rectangular and two circular circuit boards on the mic amp are not done therough wires, whose inherent flexibility usually allow for some give, but through inflexible copper circuit traces which are bent 90º at their transition point between rectangular and circular boards. These thin traces sometimes break.

Inspect these areas for breakage by bending both circular boards back and forth, especially the one closest to the connector, while you monitor with headphones for drop-outs or crackling sounds*.

Once you found the frayed or broken connection that gives out when applying force to the circular board, substitute the printed circuit trace with a soldered, multi-strand wire connection.

* The areas in question have as much as a 210VDC potential! Only use a non-conductive tool for the bending of the circuit boards or probing of the connections, and keep your hands away from the live mic's inner workings!
Logged
Klaus Heyne
German Masterworks®
www.GermanMasterworks.com

Koen

  • Newbie
  • *
  • Offline Offline
  • Posts: 33
  • Real Full Name: Koen Gisenesd
Re: Need help troubleshooting a problem with a (vintage) U67
« Reply #5 on: October 01, 2019, 04:53:12 pm »

Many thanks for your insights - I know what to do tomorrow!
I'll report back when I find something.
Have a nice day,

Koen.
Logged

Koen

  • Newbie
  • *
  • Offline Offline
  • Posts: 33
  • Real Full Name: Koen Gisenesd
Re: Need help troubleshooting a problem with a (vintage) U67
« Reply #6 on: October 02, 2019, 09:41:20 am »

Hi Klaus and others,
I tapped and moved all the trace connections between the several circuit boards with a small wooden stick.

It seems that the problem is exactly what Klaus described: the round circuit board closest to the bottom has two fine copper traces that connects it to the vertical printboard. These go to ground apparently. A past owner clearly opened up the tuchel cavity and broke those. Hence the intermittency (when turning the Tuchel screw too hard there's a tiny bit of leeway that opens the contact up).

I will soon repair it 'for real' and more durable but for the time being, I folded two tiny strips of fine aluminium sheet and stuck these under what's left of the original traces, bent those as flat as possible to the board again and bent the other side of the sheet over the frame 'legs'. I could neatly shove in the bottom part without wrinkling the aluminium and had the screws go through it nicely. It works well for the moment - it stands handling the cable, wiggling, tapping etc.

I hope I won't get banned here for this temporary unorthodox 'solution', but I really have to figure out how and where to solder a real wire to the frame 'legs' (I think they're made of some sort of - what we call 'messing' metal, not easy to solder unto).

Thank you so much for pointing me in the right direction!
Best regards,
Koen Gisen.
Logged

Kai

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 314
Re: Need help troubleshooting a problem with a (vintage) U67
« Reply #7 on: October 03, 2019, 05:39:04 pm »

In my time as a student, when I was part time working as a professional electrician for financing my life we called people replacing proper electric contacts or fuses with aluminum foil:
"chewing gum paper electricians".
This was the worst name we could call someone.

Joke aside:
Remove this as fast as you can! Sooner or later one of these aluminum foil pieces will come loose, drop somewhere and destroy something.

Takes a minute to do a proper solder job. (Bold addred by KH)
Logged

soapfoot

  • Full Member
  • ***
  • Offline Offline
  • Posts: 230
  • brad allen williams
Re: Need help troubleshooting a problem with a (vintage) U67
« Reply #8 on: October 03, 2019, 09:10:31 pm »

Just wanted to chime in to say that I found this thread immensely helpful.

We've spent the past few years intermittently chasing down problems in our three U67s in exactly the same way. First tubes/valves, then cables, then inspecting cable contacts, etc. Disassemble the mic, do something (change valves, reflow solder connections at cable connector), put it back together, "it's fixed!"

Then the problems return without warning, sometimes weeks later. Never could figure it out, and it's been infrequent enough that we've just gotten by putting up another of the U67s whenever one starts acting funny.

They've actually been stable for a little while now, but next time an issue manifests, this is the first thing we will check.
Logged
Pages: [1]   Go Up